'Print Pattern - Coding Ninjas Career Camp Fresher

Print the following pattern for the given N number of rows.

Pattern for N = 4

1
##
234
####

Input format :

Integer N (Total no. of rows)

Output format :

Pattern in N lines

Constraints:

N lies in the range: [1,20]

Sample Input:

5

Sample Output:

1
##
234
####


Solution 1:[1]

import java.util.ArrayList;
import java.util.Arrays;
import java.util.Collections;
import java.util.HashMap;
import java.util.List;
import java.util.Map;
import java.util.Scanner;
import java.util.Stack;
public class Main {
    public static void main(String[] args) {
        Scanner scn = new Scanner(System.in);
        int N = scn.nextInt();
        int val = 1;
        for (int row = 1; row <= N; row++) {
            if (row % 2 == 0) {
                // Print special character, row number of times
                for (int col = 1; col <= row; col++) {
                    System.out.print("#");
                }
            } else {
                // Print val, row number it times, increment it continuously
                for (int col = 1; col <= row; col++) {
                    System.out.print(val);
                    val++;
                }
            }
            System.out.println();
        }
        scn.close();
    }
}

Sources

This article follows the attribution requirements of Stack Overflow and is licensed under CC BY-SA 3.0.

Source: Stack Overflow

Solution Source
Solution 1 M.K. Mandawar